Scheduled Maintenance: Parchment Digitary – 05/May/2026

Scheduled for May 4, 23:00 UTC  -  May 5, 02:00 UTC

Update

We will be undergoing scheduled maintenance during this time.
Posted Apr 29, 2026 - 02:15 UTC

Scheduled

We have scheduled maintenance for the Parchment Digitary platform on 05/May/2026 from midnight to 03:00am GMT+01. You may experience a brief service interruption of up to 15 minutes during this window. We suggest completing any important tasks outside of this period to avoid disruption.

We apologize for any inconvenience and appreciate your understanding.
Posted Apr 29, 2026 - 02:13 UTC
This scheduled maintenance affects: Parchment Digitary (Parchment Digitary Learner Portal).