MyCreds Platform Availability - Payments

Incident Report for Parchment Digitary Services

Resolved

This incident has been resolved.
Posted Aug 25, 2026 - 21:59 AEST

Monitoring

Issue has been mitigated and we are monitoring the results. Payments are now available in MyCreds platform.
Posted Aug 25, 2026 - 11:15 AEST

Identified

The issue has been identified and we are working through a resolution.
Posted Aug 25, 2026 - 09:30 AEST

Investigating

We are currently addressing intermittent issues affecting payments in MyCreds platform. Users may encounter errors or have difficulty making payments. We are working to fully restore the platform and will provide the next update by 8pm 24/08/2026 MDT, or sooner if new information becomes available.

We apologize for any inconvenience and appreciate your understanding.
Posted Aug 25, 2026 - 09:18 AEST
This incident affected: MyCreds (MyCreds Learner Portal, MyCreds Graduate Verification Service).